No mod_perl For You

by john on December 22, 2002

My project for tonight was to have been installing mod_perl. As I’ve begun to play with the Google API I’ve noticed the increased time it takes to rebuild my pages so I thought I’d see what sort of improvements I see with mod_perl.

As I’m currently using Windows 2000 on my web server (toying with Mandrake 9.0 on another) I use ActiveState ActivePerl and I happened to be using ActivePerl 5.6.1 build 633. In some quick scans of the mod_perl docs I learned that 633 isn’t thread-safe and that I needed to upgrade to ActivePerl 5.8.0 build 804.

Upgrade went very smoothly and I ran mt-check.cgi to verify I had the required packages. Whoops, I was missing DBD-mysql. So I installed DBI with no problem but PPM couldn’t find DBD-mysql. Odd. There was a DBD-mysqlPP in the standard repository but no DBD-mysql.

After mucking about for awhile with no success I finally went to the Movable Type Support forums to see if anyone else had seen this problem.

Turns out they had. More than a few times.

In each case the answer was going back to ActivePerl 5.6.1 build 633. Which I did too, for now. But as soon as I get the kids down it’s back to tackle this one.

Previous post:

Next post: